Java Packages you need in Ubuntu

[email protected]:~$ java -version ; dpkg -l | grep -i java | awk '{print $2}'
java version "1.8.0_191"
Java(TM) SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.191-b12, mixed mode)
ca-certificates-java
default-jdk
default-jdk-headless
default-jre
default-jre-headless
gcj-5-jre-lib
gir1.2-javascriptcoregtk-4.0:amd64
groovy2
java-common
javascript-common
jayatana
libgcj-common
libgcj16:amd64
libjavascriptcoregtk-4.0-18:amd64
libjs-jquery
libjs-underscore
openjdk-8-jre:amd64
openjdk-8-jre-headless:amd64
oracle-java8-installer
oracle-java8-set-default
[email protected]:~$