[Solved] Unable to locate package python-pip

Error:-

[email protected]:~# sudo apt install python-pip
Reading package lists… Done
Building dependency tree Reading state information… Done
E: Unable to locate package python-pip

Solution:-

[email protected]:~# sudo apt-get update && sudo apt-get install python-pip
Get:1 http://ftp.harukasan.org/kali kali-rolling InRelease [30.5 kB]
Get:2 http://ftp.harukasan.org/kali kali-rolling/main amd64 Packages [16.5 MB]
Get:3 http://ftp.harukasan.org/kali kali-rolling/non-free amd64 Packages [195 kB]
Get:4 http://ftp.harukasan.org/kali kali-rolling/contrib amd64 Packages [99.6 kB] Fetched 6,860 kB in 44s (155 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree Reading state information… Done
The following additional packages will be installed: libffi7 libpython-all-dev libpython-dev libpython2-dev libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib python-all python-all-dev python-dev python-pip-whl python-pkg-resources python-setuptools python2-dev python2.7 python2.7-dev python2.7-minimalSuggested packages: python-setuptools-doc python2.7-docRecommended packages: python-wheelThe following NEW packages will be installed: libffi7 libpython-all-dev libpython-dev libpython2-dev libpython2.7 libpython2.7-dev python-all python-all-dev python-dev python-pip python-pip-whl python-setuptools python2-dev python2.7-devThe following packages will be upgraded: libpython2.7-minimal libpython2.7-stdlib python-pkg-resources python2.7 python2.7-minimal5 upgraded, 14 newly installed, 0 to remove and 1121 not upgraded.Need to get 10.5 MB of archives.After this operation, 22.5 MB of additional disk space will be used.Do you want to continue? [Y/n] yGet:1 http://ftp.harukasan.org/kali kali-rolling/main amd64 python2.7 amd64 2.7.18-1 [309 kB]Get:2 http://ftp.harukasan.org/kali kali-rolling/main amd64 libpython2.7-stdlib amd64 2.7.18-1 [1,885 kB]Get:3 http://ftp.harukasan.org/kali kali-rolling/main amd64 python2.7-minimal amd64 2.7.18-1 [1,355 kB] Get:4 http://ftp.harukasan.org/kali kali-rolling/main amd64 libpython2.7-minimal amd64 2.7.18-1 [395 kB] Get:5 http://ftp.harukasan.org/kali kali-rolling/main amd64 libffi7 amd64 3.3-4 [22.9 kB] Get:6 http://ftp.harukasan.org/kali kali-rolling/main amd64 libpython2.7 amd64 2.7.18-1 [1,036 kB] Get:7 http://ftp.harukasan.org/kali kali-rolling/main amd64 libpython2.7-dev amd64 2.7.18-1 [2,469 kB] Get:8 http://ftp.harukasan.org/kali kali-rolling/main amd64 libpython2-dev amd64 2.7.17-2 [21.0 kB] Get:9 http://ftp.harukasan.org/kali kali-rolling/main amd64 libpython-dev amd64 2.7.17-2 [21.0 kB] Get:10 http://ftp.harukasan.org/kali kali-rolling/main amd64 libpython-all-dev amd64 2.7.17-2 [1,068 B] Get:11 http://ftp.harukasan.org/kali kali-rolling/main amd64 python-all amd64 2.7.17-2 [1,048 B] Get:12 http://ftp.harukasan.org/kali kali-rolling/main amd64 python2.7-dev amd64 2.7.18-1 [292 kB] Get:13 http://ftp.harukasan.org/kali kali-rolling/main amd64 python2-dev amd64 2.7.17-2 [1,220 B] Get:14 http://ftp.harukasan.org/kali kali-rolling/main amd64 python-dev amd64 2.7.17-2 [1,196 B] Get:15 http://ftp.harukasan.org/kali kali-rolling/main amd64 python-all-dev amd64 2.7.17-2 [1,072 B] Get:16 http://ftp.harukasan.org/kali kali-rolling/main amd64 python-pip-whl all 20.0.2-5kali1 [1,842 kB] Get:17 http://ftp.harukasan.org/kali kali-rolling/main amd64 python-pip all 20.0.2-5kali1 [276 kB] Get:18 http://ftp.harukasan.org/kali kali-rolling/main amd64 python-pkg-resources all 44.0.0-3 [181 kB] Get:19 http://ftp.harukasan.org/kali kali-rolling/main amd64 python-setuptools all 44.0.0-3 [382 kB] Fetched 10.5 MB in 1min 23s (126 kB/s) Reading changelogs… Done(Reading database … 255564 files and directories currently installed.)Preparing to unpack …/00-python2.7_2.7.18-1_amd64.deb …Unpacking python2.7 (2.7.18-1) over (2.7.17-1) …Preparing to unpack …/01-libpython2.7-stdlib_2.7.18-1_amd64.deb …Unpacking libpython2.7-stdlib:amd64 (2.7.18-1) over (2.7.17-1) …Preparing to unpack …/02-python2.7-minimal_2.7.18-1_amd64.deb …Unpacking python2.7-minimal (2.7.18-1) over (2.7.17-1) …Preparing to unpack …/03-libpython2.7-minimal_2.7.18-1_amd64.deb …Unpacking libpython2.7-minimal:amd64 (2.7.18-1) over (2.7.17-1) …Selecting previously unselected package libffi7:amd64.Preparing to unpack …/04-libffi7_3.3-4_amd64.deb …Unpacking libffi7:amd64 (3.3-4) …Selecting previously unselected package libpython2.7:amd64.Preparing to unpack …/05-libpython2.7_2.7.18-1_amd64.deb …Unpacking libpython2.7:amd64 (2.7.18-1) …Selecting previously unselected package libpython2.7-dev:amd64.Preparing to unpack …/06-libpython2.7-dev_2.7.18-1_amd64.deb …Unpacking libpython2.7-dev:amd64 (2.7.18-1) …Selecting previously unselected package libpython2-dev:amd64.Preparing to unpack …/07-libpython2-dev_2.7.17-2_amd64.deb …Unpacking libpython2-dev:amd64 (2.7.17-2) …Selecting previously unselected package libpython-dev:amd64.Preparing to unpack …/08-libpython-dev_2.7.17-2_amd64.deb …Unpacking libpython-dev:amd64 (2.7.17-2) …Selecting previously unselected package libpython-all-dev:amd64.Preparing to unpack …/09-libpython-all-dev_2.7.17-2_amd64.deb …Unpacking libpython-all-dev:amd64 (2.7.17-2) …Selecting previously unselected package python-all.Preparing to unpack …/10-python-all_2.7.17-2_amd64.deb …Unpacking python-all (2.7.17-2) …Selecting previously unselected package python2.7-dev.Preparing to unpack …/11-python2.7-dev_2.7.18-1_amd64.deb …Unpacking python2.7-dev (2.7.18-1) …Selecting previously unselected package python2-dev.Preparing to unpack …/12-python2-dev_2.7.17-2_amd64.deb …Unpacking python2-dev (2.7.17-2) …Selecting previously unselected package python-dev.Preparing to unpack …/13-python-dev_2.7.17-2_amd64.deb …Unpacking python-dev (2.7.17-2) …Selecting previously unselected package python-all-dev.Preparing to unpack …/14-python-all-dev_2.7.17-2_amd64.deb …Unpacking python-all-dev (2.7.17-2) …Selecting previously unselected package python-pip-whl.Preparing to unpack …/15-python-pip-whl_20.0.2-5kali1_all.deb …Unpacking python-pip-whl (20.0.2-5kali1) …Selecting previously unselected package python-pip.Preparing to unpack …/16-python-pip_20.0.2-5kali1_all.deb …Unpacking python-pip (20.0.2-5kali1) …Preparing to unpack …/17-python-pkg-resources_44.0.0-3_all.deb …Unpacking python-pkg-resources (44.0.0-3) over (44.0.0-1) …Selecting previously unselected package python-setuptools.Preparing to unpack …/18-python-setuptools_44.0.0-3_all.deb …Unpacking python-setuptools (44.0.0-3) …Setting up python-pkg-resources (44.0.0-3) …Setting up libffi7:amd64 (3.3-4) …Setting up libpython2.7-minimal:amd64 (2.7.18-1) …Setting up python2.7-minimal (2.7.18-1) …Setting up python-setuptools (44.0.0-3) …Setting up python-pip-whl (20.0.2-5kali1) …Setting up libpython2.7-stdlib:amd64 (2.7.18-1) …Setting up python-pip (20.0.2-5kali1) …Setting up libpython2.7:amd64 (2.7.18-1) …Setting up libpython2.7-dev:amd64 (2.7.18-1) …Setting up python2.7 (2.7.18-1) …Setting up python-all (2.7.17-2) …Setting up libpython2-dev:amd64 (2.7.17-2) …Setting up python2.7-dev (2.7.18-1) …Setting up python2-dev (2.7.17-2) …Setting up libpython-dev:amd64 (2.7.17-2) …Setting up python-dev (2.7.17-2) …Setting up libpython-all-dev:amd64 (2.7.17-2) …Setting up python-all-dev (2.7.17-2) …Processing triggers for desktop-file-utils (0.24-1) …Processing triggers for mime-support (3.64) …Processing triggers for libc-bin (2.29-9) …Processing triggers for man-db (2.9.0-2) …Processing triggers for kali-menu (2020.1.7) …

[email protected]:~# dpkg -l | grep pip
ii libpipeline1:amd64 1.5.2-2 amd64 Unix process
pipeline manipulation libraryii
pipal 3.1-0kali0 all Statistical analysis on password dumpsii
python-pip 20.0.2-5kali1 all Python package installerii
python-pip-whl 20.0.2-5kali1 all Python package installer

[email protected]:~#

Leave a Reply