Home » Uncategorized » [Solved] TeamViewer + Ubuntu Dependencies Problem libc6-i386 lib32asound2 lib32z1 ia32-libs

[Solved] TeamViewer + Ubuntu Dependencies Problem libc6-i386 lib32asound2 lib32z1 ia32-libs

Issue #1

root@D2:/home/navdeepd2# teamviewer

Init…
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup…
/opt/teamviewer/tv_bin/script/tvw_exec_legacy: line 9: /opt/teamviewer/tv_bin/wine/bin/wineserver: No such file or directory
/opt/teamviewer/tv_bin/script/tvw_profile_legacy: line 127: /opt/teamviewer/tv_bin/wine/bin/wine: No such file or directory

Issue #2

dpkg: dependency problems prevent configuration of teamviewer:
teamviewer depends on libc6-i386 (>= 2.11); however:
Package libc6-i386 is not installed.
teamviewer depends on lib32asound2; however:
Package lib32asound2 is not installed.
teamviewer depends on lib32z1; however:
Package lib32z1 is not installed.
teamviewer depends on ia32-libs; however:
Package ia32-libs is not installed.

dpkg: error processing package teamviewer (–install):
dependency problems – leaving unconfigured
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) …
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) …
Processing triggers for mime-support (3.59ubuntu1) …
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) …

Solution:-

root@D2:/home/navdeepd2# dpkg -i /tmp/teamviewer_i386.deb
Selecting previously unselected package teamviewer:i386.
(Reading database … 218334 files and directories currently installed.)
Preparing to unpack /tmp/teamviewer_i386.deb …
Unpacking teamviewer:i386 (12.0.93330) …
dpkg: dependency problems prevent configuration of teamviewer:i386:
teamviewer:i386 depends on libc6 (>= 2.11).
teamviewer:i386 depends on libgcc1.
teamviewer:i386 depends on libasound2.
teamviewer:i386 depends on libdbus-1-3.
teamviewer:i386 depends on libexpat1.
teamviewer:i386 depends on libfontconfig1.
teamviewer:i386 depends on libfreetype6.
teamviewer:i386 depends on libjpeg62.
teamviewer:i386 depends on libsm6.
teamviewer:i386 depends on libxdamage1.
teamviewer:i386 depends on libxext6.
teamviewer:i386 depends on libxfixes3.
teamviewer:i386 depends on libxinerama1.
teamviewer:i386 depends on libxrandr2.
teamviewer:i386 depends on libxrender1.
teamviewer:i386 depends on libxtst6.
teamviewer:i386 depends on zlib1g.

dpkg: error processing package teamviewer:i386 (–install):
dependency problems – leaving unconfigured
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) …
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) …
Processing triggers for mime-support (3.59ubuntu1) …
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) …
Errors were encountered while processing:
teamviewer:i386
root@D2:/home/navdeepd2# apt-get install libgcc1
Reading package lists… Done
Building dependency tree
Reading state information… Done
libgcc1 is already the newest version (1:6.0.1-0ubuntu1).
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
teamviewer:i386 : Depends: libc6:i386 (>= 2.11) but it is not going to be installed
Depends: libgcc1:i386 but it is not going to be installed
Depends: libasound2:i386
Depends: libdbus-1-3:i386 but it is not going to be installed
Depends: libexpat1:i386 but it is not going to be installed
Depends: libfontconfig1:i386 but it is not going to be installed
Depends: libfreetype6:i386 but it is not going to be installed
Depends: libjpeg62:i386 but it is not going to be installed
Depends: libsm6:i386 but it is not going to be installed
Depends: libxdamage1:i386 but it is not going to be installed
Depends: libxext6:i386 but it is not going to be installed
Depends: libxfixes3:i386 but it is not going to be installed
Depends: libxinerama1:i386 but it is not going to be installed
Depends: libxrandr2:i386 but it is not going to be installed
Depends: libxrender1:i386 but it is not going to be installed
Depends: libxtst6:i386 but it is not going to be installed
Depends: zlib1g:i386 but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
root@D2:/home/navdeepd2# apt-get -f install
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following additional packages will be installed:
gcc-6-base:i386 libasound2:i386 libc6:i386 libdbus-1-3:i386 libexpat1:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt20:i386 libgpg-error0:i386 libice6:i386 libjpeg62:i386
liblzma5:i386 libpcre3:i386 libpng12-0:i386 libselinux1:i386 libsm6:i386 libsystemd0:i386 libuuid1:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
libxfixes3:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libxtst6:i386 zlib1g:i386
Suggested packages:
libasound2-plugins:i386 glibc-doc:i386 locales:i386 rng-tools:i386
The following NEW packages will be installed:
gcc-6-base:i386 libasound2:i386 libc6:i386 libdbus-1-3:i386 libexpat1:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt20:i386 libgpg-error0:i386 libice6:i386 libjpeg62:i386
liblzma5:i386 libpcre3:i386 libpng12-0:i386 libselinux1:i386 libsm6:i386 libsystemd0:i386 libuuid1:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
libxfixes3:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libxtst6:i386 zlib1g:i386
0 upgraded, 31 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 5,453 kB of archives.
After this operation, 19.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://in.archive.ubuntu.com/ubuntu xenial/main i386 gcc-6-base i386 6.0.1-0ubuntu1 [14.3 kB]
Get:2 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libgcc1 i386 1:6.0.1-0ubuntu1 [46.8 kB]
Get:3 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 libc6 i386 2.23-0ubuntu10 [2,266 kB]
Get:4 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libasound2 i386 1.1.0-0ubuntu1 [370 kB]
Get:5 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libgpg-error0 i386 1.21-2ubuntu1 [37.3 kB]
Get:6 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 libgcrypt20 i386 1.6.5-2ubuntu0.4 [321 kB]
Get:7 http://in.archive.ubuntu.com/ubuntu xenial/main i386 liblzma5 i386 5.1.1alpha+20120614-2ubuntu2 [84.2 kB]
Get:8 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libpcre3 i386 2:8.38-3.1 [223 kB]
Get:9 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libselinux1 i386 2.4-3build2 [60.7 kB]
Get:10 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 libsystemd0 i386 229-4ubuntu21.2 [222 kB]
Get:11 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 libdbus-1-3 i386 1.10.6-1ubuntu3.3 [173 kB]
Get:12 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 libexpat1 i386 2.1.0-7ubuntu0.16.04.3 [74.1 kB]
Get:13 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 zlib1g i386 1:1.2.8.dfsg-2ubuntu4.1 [52.1 kB]
Get:14 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libpng12-0 i386 1.2.54-1ubuntu1 [122 kB]
Get:15 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 libfreetype6 i386 2.6.1-0.1ubuntu2.3 [330 kB]
Get:16 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 libfontconfig1 i386 2.11.94-0ubuntu1.1 [140 kB]
Get:17 http://in.archive.ubuntu.com/ubuntu xenial/universe i386 libjpeg62 i386 1:6b2-2 [80.5 kB]
Get:18 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libice6 i386 2:1.0.9-1 [38.2 kB]
Get:19 http://in.archive.ubuntu.com/ubuntu xenial-updates/main i386 libuuid1 i386 2.27.1-6ubuntu3.4 [16.3 kB]
Get:20 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libsm6 i386 2:1.2.2-1 [14.8 kB]
Get:21 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxau6 i386 1:1.0.8-1 [8,352 B]
Get:22 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxdmcp6 i386 1:1.1.2-1.1 [11.4 kB]
Get:23 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxcb1 i386 1.11.1-1ubuntu1 [44.1 kB]
Get:24 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libx11-6 i386 2:1.6.3-1ubuntu2 [592 kB]
Get:25 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxdamage1 i386 1:1.1.4-2 [6,812 B]
Get:26 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxext6 i386 2:1.3.3-1 [31.6 kB]
Get:27 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxfixes3 i386 1:5.0.1-2 [11.4 kB]
Get:28 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxinerama1 i386 2:1.1.3-1 [7,900 B]
Get:29 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxrender1 i386 1:0.9.9-0ubuntu1 [19.2 kB]
Get:30 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxrandr2 i386 2:1.5.0-1 [19.1 kB]
Get:31 http://in.archive.ubuntu.com/ubuntu xenial/main i386 libxtst6 i386 2:1.2.2-1 [13.8 kB]
Fetched 5,453 kB in 12s (433 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages …
Selecting previously unselected package gcc-6-base:i386.
(Reading database … 218635 files and directories currently installed.)
Preparing to unpack …/gcc-6-base_6.0.1-0ubuntu1_i386.deb …
Unpacking gcc-6-base:i386 (6.0.1-0ubuntu1) …
Selecting previously unselected package libgcc1:i386.
Preparing to unpack …/libgcc1_1%3a6.0.1-0ubuntu1_i386.deb …
Unpacking libgcc1:i386 (1:6.0.1-0ubuntu1) …
Selecting previously unselected package libc6:i386.
Preparing to unpack …/libc6_2.23-0ubuntu10_i386.deb …
Unpacking libc6:i386 (2.23-0ubuntu10) …
Selecting previously unselected package libasound2:i386.
Preparing to unpack …/libasound2_1.1.0-0ubuntu1_i386.deb …
Unpacking libasound2:i386 (1.1.0-0ubuntu1) …
Selecting previously unselected package libgpg-error0:i386.
Preparing to unpack …/libgpg-error0_1.21-2ubuntu1_i386.deb …
Unpacking libgpg-error0:i386 (1.21-2ubuntu1) …
Selecting previously unselected package libgcrypt20:i386.
Preparing to unpack …/libgcrypt20_1.6.5-2ubuntu0.4_i386.deb …
Unpacking libgcrypt20:i386 (1.6.5-2ubuntu0.4) …
Selecting previously unselected package liblzma5:i386.
Preparing to unpack …/liblzma5_5.1.1alpha+20120614-2ubuntu2_i386.deb …
Unpacking liblzma5:i386 (5.1.1alpha+20120614-2ubuntu2) …
Selecting previously unselected package libpcre3:i386.
Preparing to unpack …/libpcre3_2%3a8.38-3.1_i386.deb …
Unpacking libpcre3:i386 (2:8.38-3.1) …
Selecting previously unselected package libselinux1:i386.
Preparing to unpack …/libselinux1_2.4-3build2_i386.deb …
Unpacking libselinux1:i386 (2.4-3build2) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Processing triggers for man-db (2.7.5-1) …
Setting up gcc-6-base:i386 (6.0.1-0ubuntu1) …
Setting up libgcc1:i386 (1:6.0.1-0ubuntu1) …
Setting up libc6:i386 (2.23-0ubuntu10) …
Setting up libgpg-error0:i386 (1.21-2ubuntu1) …
Setting up libgcrypt20:i386 (1.6.5-2ubuntu0.4) …
Setting up liblzma5:i386 (5.1.1alpha+20120614-2ubuntu2) …
Setting up libpcre3:i386 (2:8.38-3.1) …
Setting up libselinux1:i386 (2.4-3build2) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Selecting previously unselected package libsystemd0:i386.
(Reading database … 218962 files and directories currently installed.)
Preparing to unpack …/libsystemd0_229-4ubuntu21.2_i386.deb …
Unpacking libsystemd0:i386 (229-4ubuntu21.2) …
Selecting previously unselected package libdbus-1-3:i386.
Preparing to unpack …/libdbus-1-3_1.10.6-1ubuntu3.3_i386.deb …
Unpacking libdbus-1-3:i386 (1.10.6-1ubuntu3.3) …
Selecting previously unselected package libexpat1:i386.
Preparing to unpack …/libexpat1_2.1.0-7ubuntu0.16.04.3_i386.deb …
Unpacking libexpat1:i386 (2.1.0-7ubuntu0.16.04.3) …
Selecting previously unselected package zlib1g:i386.
Preparing to unpack …/zlib1g_1%3a1.2.8.dfsg-2ubuntu4.1_i386.deb …
Unpacking zlib1g:i386 (1:1.2.8.dfsg-2ubuntu4.1) …
Selecting previously unselected package libpng12-0:i386.
Preparing to unpack …/libpng12-0_1.2.54-1ubuntu1_i386.deb …
Unpacking libpng12-0:i386 (1.2.54-1ubuntu1) …
Selecting previously unselected package libfreetype6:i386.
Preparing to unpack …/libfreetype6_2.6.1-0.1ubuntu2.3_i386.deb …
Unpacking libfreetype6:i386 (2.6.1-0.1ubuntu2.3) …
Selecting previously unselected package libfontconfig1:i386.
Preparing to unpack …/libfontconfig1_2.11.94-0ubuntu1.1_i386.deb …
Unpacking libfontconfig1:i386 (2.11.94-0ubuntu1.1) …
Selecting previously unselected package libjpeg62:i386.
Preparing to unpack …/libjpeg62_1%3a6b2-2_i386.deb …
Unpacking libjpeg62:i386 (1:6b2-2) …
Selecting previously unselected package libice6:i386.
Preparing to unpack …/libice6_2%3a1.0.9-1_i386.deb …
Unpacking libice6:i386 (2:1.0.9-1) …
Selecting previously unselected package libuuid1:i386.
Preparing to unpack …/libuuid1_2.27.1-6ubuntu3.4_i386.deb …
Unpacking libuuid1:i386 (2.27.1-6ubuntu3.4) …
Selecting previously unselected package libsm6:i386.
Preparing to unpack …/libsm6_2%3a1.2.2-1_i386.deb …
Unpacking libsm6:i386 (2:1.2.2-1) …
Selecting previously unselected package libxau6:i386.
Preparing to unpack …/libxau6_1%3a1.0.8-1_i386.deb …
Unpacking libxau6:i386 (1:1.0.8-1) …
Selecting previously unselected package libxdmcp6:i386.
Preparing to unpack …/libxdmcp6_1%3a1.1.2-1.1_i386.deb …
Unpacking libxdmcp6:i386 (1:1.1.2-1.1) …
Selecting previously unselected package libxcb1:i386.
Preparing to unpack …/libxcb1_1.11.1-1ubuntu1_i386.deb …
Unpacking libxcb1:i386 (1.11.1-1ubuntu1) …
Selecting previously unselected package libx11-6:i386.
Preparing to unpack …/libx11-6_2%3a1.6.3-1ubuntu2_i386.deb …
Unpacking libx11-6:i386 (2:1.6.3-1ubuntu2) …
Selecting previously unselected package libxdamage1:i386.
Preparing to unpack …/libxdamage1_1%3a1.1.4-2_i386.deb …
Unpacking libxdamage1:i386 (1:1.1.4-2) …
Selecting previously unselected package libxext6:i386.
Preparing to unpack …/libxext6_2%3a1.3.3-1_i386.deb …
Unpacking libxext6:i386 (2:1.3.3-1) …
Selecting previously unselected package libxfixes3:i386.
Preparing to unpack …/libxfixes3_1%3a5.0.1-2_i386.deb …
Unpacking libxfixes3:i386 (1:5.0.1-2) …
Selecting previously unselected package libxinerama1:i386.
Preparing to unpack …/libxinerama1_2%3a1.1.3-1_i386.deb …
Unpacking libxinerama1:i386 (2:1.1.3-1) …
Selecting previously unselected package libxrender1:i386.
Preparing to unpack …/libxrender1_1%3a0.9.9-0ubuntu1_i386.deb …
Unpacking libxrender1:i386 (1:0.9.9-0ubuntu1) …
Selecting previously unselected package libxrandr2:i386.
Preparing to unpack …/libxrandr2_2%3a1.5.0-1_i386.deb …
Unpacking libxrandr2:i386 (2:1.5.0-1) …
Selecting previously unselected package libxtst6:i386.
Preparing to unpack …/libxtst6_2%3a1.2.2-1_i386.deb …
Unpacking libxtst6:i386 (2:1.2.2-1) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Setting up libasound2:i386 (1.1.0-0ubuntu1) …
Setting up libsystemd0:i386 (229-4ubuntu21.2) …
Setting up libdbus-1-3:i386 (1.10.6-1ubuntu3.3) …
Setting up libexpat1:i386 (2.1.0-7ubuntu0.16.04.3) …
Setting up zlib1g:i386 (1:1.2.8.dfsg-2ubuntu4.1) …
Setting up libpng12-0:i386 (1.2.54-1ubuntu1) …
Setting up libfreetype6:i386 (2.6.1-0.1ubuntu2.3) …
Setting up libfontconfig1:i386 (2.11.94-0ubuntu1.1) …
Setting up libjpeg62:i386 (1:6b2-2) …
Setting up libice6:i386 (2:1.0.9-1) …
Setting up libuuid1:i386 (2.27.1-6ubuntu3.4) …
Setting up libsm6:i386 (2:1.2.2-1) …
Setting up libxau6:i386 (1:1.0.8-1) …
Setting up libxdmcp6:i386 (1:1.1.2-1.1) …
Setting up libxcb1:i386 (1.11.1-1ubuntu1) …
Setting up libx11-6:i386 (2:1.6.3-1ubuntu2) …
Setting up libxdamage1:i386 (1:1.1.4-2) …
Setting up libxext6:i386 (2:1.3.3-1) …
Setting up libxfixes3:i386 (1:5.0.1-2) …
Setting up libxinerama1:i386 (2:1.1.3-1) …
Setting up libxrender1:i386 (1:0.9.9-0ubuntu1) …
Setting up libxrandr2:i386 (2:1.5.0-1) …
Setting up libxtst6:i386 (2:1.2.2-1) …
Setting up teamviewer:i386 (12.0.93330) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
root@D2:/home/navdeepd2#

root@D2:/home/navdeepd2# teamviewer

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*